Question

Wrong Browser Mobile Safari, should be Google Search App

  • 19 November 2020
  • 3 replies
  • 135 views

I'm seeing a user tracked with the following browser user agent:

Mozilla/5.0 (iPhone; CPU iPhone OS 14_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) GSA/132.0.339365841 Mobile/15E148 Safari/604.1

However, it is classified by Mixpanel attributes as Browser Mobile Safari.

A quick Google Search has led me to believe this is actually the Google Search App:

https://developers.whatismybrowser.com/useragents/explore/operating_platform/iphone/7

 

Is this something that could be fixed?


3 replies

Userlevel 5
Badge +3

@gerardnijboer —

 

It’s certainly something that we can raise as a bug if we are able to replicate the issue. Have you been able to download the google search app and see that it is consistently misclassified? 

I’m curious, what property was used to collect the following browser?

Mozilla/5.0 (iPhone; CPU iPhone OS 14_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) GSA/132.0.339365841 Mobile/15E148 Safari/604.1

Since Mozilla is run by Firefox I’m wondering if it is referencing a different value and not the browser. 

 

Would love to learn more!

Hey Cherise,

Yeah, I can replicate and confirm the issue. Using an iPhone XR with iOS 14.3 and the Google Search app.

To be complete, that's the "Google” app from the App Store:
https://apps.apple.com/us/app/google/id284815942

When I go into the Mixpanel analytics, the event properties are:

Browser: Mobile Safari
Browser Version: null
Device: iPhone
OS: iOS

If you would need some Mixpanel Distinct IDs or Insert IDs to analyze, feel free to let me know.
Happy to help.

Userlevel 5
Badge +3

@gerardnijboer — Thanks for the added detail! 

 

We are in the process of creating an escalation process from community to our support team, but in the meantime this sounds like something they would be interested in addressing. Do you mind going the extra step to create a support ticket so we can keep a log of this and create a bug report? http://mixpanel.com/get-support

 

Reply


Mixpanel