Hi everyone :wave: new to the community! I'm hopi...
# questions
Hi everyone 👋 new to the community! I'm hoping to get some advice on event property naming conventions. We have a main funnel in our app called the "create consult funnel". We're in the process of adding more event properties to this funnel, and my Engineering team asked if I wanted to add a prefix to each of these new properties to denote that they're part of this funnel. This was suggested to help differentiate event properties associated with the create consult funnel. The rationale for doing this is that we may have some property names that could be too vague (e.g. price_type) and we should specify they are part of this funnel to avoid confusion or having duplicated event properties. So something like this:
Copy code
return {
My concern is that this creates another layer of naming convention within the event properties to be managed, understood, and scaled. Has anyone run into something similar or have any suggestions of how to keep this low maintenance/scalable? Thanks in advance.
👍 2