Solved

Mixpanel by default prefixing +1 on every phone number

  • 22 November 2019
  • 1 reply
  • 123 views

Badge

I am trying to upload csv with $phone and $country_code as people properties to an existing list of users but mixpanel is automatically prefixing +1 on every phone number i understand mixpanel generates $country_code based on IP address but it's not happening ex. if i assign $country_code = +91 and $phone = 990*****34 result will be Phone = +191990*****34 which is not correct. I also tried removing $country_code then it gives +1990*****34 its not retrieving $coutry_code from IP address


icon

Best answer by annecamacho 27 November 2019, 02:08

Hey @Abdul Azeez

Have you tried setting the $phone number along as one and not setting the $country_code separately? For example just sending $phone = +91990*****34?

I read their documentation and it looks like if the number if not automatically populated with their country code (+91), it will default to adding +1 to the number and looking at the country code - more info here https://help.mixpanel.com/hc/en-us/articles/115004708186#reserved-properties-for-user-profiles.



View original

1 reply

Userlevel 3
Badge

Hey @Abdul Azeez

Have you tried setting the $phone number along as one and not setting the $country_code separately? For example just sending $phone = +91990*****34?

I read their documentation and it looks like if the number if not automatically populated with their country code (+91), it will default to adding +1 to the number and looking at the country code - more info here https://help.mixpanel.com/hc/en-us/articles/115004708186#reserved-properties-for-user-profiles.



Reply