Question

Lookup tables aren't being found by API

  • 15 June 2022
  • 0 replies
  • 18 views

I have recently been trying to ingest updated lookup tables through the ingestion API endpoint. After uploading the initial tables manually (Side note: It would be really nice if this could also be done through the api.) I have attempted to call the update endpoint but I am getting a 404 with the error message

“{"error":"getByKeyId failed: cache.GetDataGroupByKey failed: data group not found","status":0}”

I can see my lookup tables in the mixpanel UI and I called the endpoint with the ids found there. I also tried using the list lookup tables endpoint, this returns successfully but the results list is null. So it seems the API is unable to get at my lookup tables, but I’m not entirely sure? I thought it may have had something to do with the permissions on the service account used for the authorization but I have tried with different service accounts and different permissions to no avail. Am I missing something? Is this a known issue? Any help would be appreciated!


0 replies

Be the first to reply!

Reply