Question

Data missing or lost

  • 9 April 2019
  • 4 replies
  • 153 views

Badge

I currently have a Unity Project (using the Unity 1.3.1 SDK ) in which a tracking event is sent when the user progresses through the app. These events are called sequentially, however, mixpanel seems to be missing some if not most of the events, example: 2, 3, 5, 7, 8 (missing/lost 1, 4, 6)

The events are called a few seconds after each other, The flush buffer is set to 2 seconds (also tested at 30 seconds and 60 seconds), the function is the simple Mixpanel.Track(action, prop); call.

The odd part is that some of the events are making it to the website UI.

Any insight would be appreciated.



4 replies

Badge

An update. It has been roughly 24 hours since the intermittent event calls, and the events still have not been displayed on the mixpanel UI. Earlier event calls this morning are receiving the same issue where only some of the event data is being sent.


Userlevel 3
Badge

@normanpham It would be helpful to know a bit more of what you are seeing. I am pondering some questions...

Do the same events go missing every time?

What does your call look like?

Are there any error logs or other information that might help to debug?


Badge

I am experiencing a similar issue here. Any updates on this issue?

Userlevel 4
Badge +3

Hi @muhammadssr —

Can you share more details about what you are experiencing?

Details such as the following would help us understand more about what is going on:

  • Are you looking at a specific report?
  • Are you seeing error messages? Is there an error log or other information that can help debug this?
  • How are you sending this event to Mixpanel (what does the script or call look like?)
  • Do the events show up in a report and go away? 
  • Is it the same event every time?
  • How long are you waiting? Do they show up eventually?

In the meantime, we recently published this #mpknowledgedrop on  common data discrepancies that might help you out. 

 

Reply