Solved

Chrome browser stopped tracking events - no ad blockers


Userlevel 2
Badge

Hi team,

Chrome browser no longer tracks any of my client side actions anymore. It's not happening for our users of Chrome, just me. So it's mainly just annoying for testing. Safari and Firefox both work fine.

I don't have any ad blockers installed and the only extensions are 1password and WhatRuns. I've tried disabling both of these but still not working.

Is there a setting in Chrome that can prevent Mixpanel tracking? It's been a problem for a few months now but only thought to ask just now. I'm currently on Chrome v75.

Cheers


icon

Best answer by willyv 8 July 2019, 22:47

Hi @matt_au! I had a similar issue before. There is a "Do not Track Feature" that Chrome has in their browsers.

You might want to check if the Chrome browser has the “Do Not Track” features set? To adjust the setting, you can refer here for the details. You can also run this method on your chrome console dev tools mixpanel.has_opted_out_tracking(); to check if it is true or false.

Hopefully this helps get your issue resolved!


View original

3 replies

Userlevel 5
Badge +3

We created a checklist on what can prevent users from being tracked:

https://community.mixpanel.com/building-analysis-reports-14/what-can-affect-users-from-being-tracked-3509

 

Hope this helps anyone stumbling on this post in the future!

Userlevel 2
Badge

Thanks Willyv,

This was exactly it! Appreciate the help.


Userlevel 3
Badge

Hi @matt_au! I had a similar issue before. There is a "Do not Track Feature" that Chrome has in their browsers.

You might want to check if the Chrome browser has the “Do Not Track” features set? To adjust the setting, you can refer here for the details. You can also run this method on your chrome console dev tools mixpanel.has_opted_out_tracking(); to check if it is true or false.

Hopefully this helps get your issue resolved!


Reply