Question

Target Criteria in messages always empty?


Userlevel 3
Badge

No matter how I try and filter the message criteria, I always get the message "0 people will get this message".

Even if I only filter with "all users" or "all that use chrome" or even filtering by a common action.

Am I doing something wrong?



9 replies

Userlevel 3
Badge

Hey @iancasarim! Can you share what type of message you are creating and your target message criteria?


Userlevel 3
Badge

Hey, thanks for answering. Sorry for not printing. It follows:


The message was just a simple text as a test for an email message.


Userlevel 3
Badge

Hey @iancasarim, no worries 🙂 thanks for sharing! Sorry I have one more question, can you share how you are storing your email people property?

is it set like the example below?

mixpanel.people.set({
$email: "joe.doe@example.com"
});

The reason I ask is because I was reading their email article and it says that you can only send emails to users who have the special people property of $email. It could be that this is what is causing your email target criteria count to 0?


Userlevel 3
Badge

I'm passing this and other information this way:


mixpanel.track(title, data);
}

public identifyUser() {
if (!environment.production) {
return;
}

const user: any = this.globals.userData;
if (!user) {
return;
}
const data = {
email: user.email,
name: user.given_name + ' ' + user.middle_name,
role: user.role || ''
};
mixpanel.identify(data.email);
mixpanel.people.set(data);
}

I use other mixpanel features normally this way, including actions and searching for users by email -- is this correct?



Userlevel 3
Badge

@iancasarim it looks like you might need to change the way you are setting your email on your people.set . It might look something like this?

mixpanel.people.set({
$email: data.email
});

I would test it out in a different project and see if that fixes your target criteria of 0


Userlevel 3
Badge

I think that's not the problem. As you can see in my prints, i can already match and see people's emails normally. I even used the same filter criteria in another page and it works fine. Why its not working on the message screen?




Userlevel 2
Badge +1

Hi @iancasarim- you want to use $email rather than email when setting people properties. If you click on the default filters in the message targeting you'll see that we look for people who have the $email property set. So even though these users will show up in the explore report, they can't be sent a message since Mixpanel can't read the $email property.


Userlevel 3
Badge

Thanks for clarifying @pranav!


Userlevel 2
Badge +1

@iancasarim- I'm the Product Manager for this feature in Mixpanel. Can you please email me with a link to the saved message / your project? I can try to help.


Reply